summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 436bbf46278a..7a69ba845f05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,16 @@ pkgdesc="A python library to interface with the ipef3 command-line tool"
arch=('any')
url="https://github.com/thiezn/iperf3-python"
license=('GPL')
-makedepends=('python-pip')
+depends=('python' 'iperf3')
+source=("https://github.com/thiezn/iperf3-python/archive/v$pkgver.tar.gz")
+sha1sums=('6768f369167ee509ce20416be28846fc829a50af')
+
+build() {
+ cd $srcdir/iperf3-python-$pkgver
+ python setup.py build
+}
package() {
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps iperf3
+ cd $srcdir/iperf3-python-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}