summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a8c8124a42f5..34b80a34fc57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=ipware
pkgname=python-ipware
-pkgver=0.9.0
+pkgver=2.0.0
pkgrel=1
pkgdesc="Returns the best matched IP address from a given HTTP(s) header in Python"
arch=('any')
@@ -11,21 +11,16 @@ license=('MIT')
makedepends=('python-setuptools')
conflicts=('python-django-ipware')
source=("$pkgname-$pkgver.src.tar.gz::https://github.com/un33k/python-ipware/archive/v$pkgver.tar.gz")
-sha256sums=('527c2b813688628d0dde2e35eddaf02994fc879dde9b38e76662ca16ebe6413e')
+sha256sums=('79c6a1759f6e814b3d1148eda2eb5f32206303d1d5a5e89a5f6b55f06735e303')
build() {
cd "$pkgname-$pkgver" || exit
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$pkgname-$pkgver" || exit
-
- export PYTHONHASHSEED=0
- python setup.py install --skip-build \
- --optimize=1 \
- --prefix=/usr \
- --root="$pkgdir"
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}