summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12367659d860
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Liu Zhe <cruise.pas@gmail.com>
+
+pkgname=python-json-tricks
+pkgver=3.12.2
+pkgrel=1
+pkgdesc="Extra features for Python's JSON"
+arch=('any')
+url='https://github.com/mverleg/pyjson_tricks'
+license=('BSD')
+depends=('python')
+optdepends=('python-numpy' 'python-pytz' 'python-pandas')
+makedepends=('python-setuptools')
+source=("pyjson_tricks-$pkgver.tar.gz::https://github.com/mverleg/pyjson_tricks/archive/v$pkgver.tar.gz")
+sha1sums=('29537cb4a210dcbb6f6c130994b39730b64d831c')
+
+build() {
+ cd "$srcdir"/pyjson_tricks-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir"/pyjson_tricks-$pkgver
+ python setup.py install --skip-build -O1 --root="$pkgdir"
+ install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}