summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 13 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 33313ed8807c..00ba7ab47283 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,23 @@
-#Automatically generated by pip2arch on 2014-04-28
+#Maintainer: John Jenkins twodopeshaggy@gmail.com
-pkgname=python-kitchen
-pkgver=1.1.1
-pkgrel=2
-pkgdesc="Kitchen contains a cornucopia of useful code"
+pkgname=python3-kitchen
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="Useful snippets of python code"
url="https://fedorahosted.org/kitchen"
-depends=('python2' )
-makedepends=('python2')
+depends=('python' )
+makedepends=('python')
license=('LGPLv2+')
arch=('any')
-source=('https://pypi.python.org/packages/source/k/kitchen/kitchen-1.1.1.tar.gz')
-md5sums=('059d7ce048ca1d0fb53e6755145137b0')
-provides=(python2-kitchen)
-conflicts=(python2-kitchen)
+source=(https://github.com/fedora-infra/kitchen/archive/$pkgver.tar.gz)
+md5sums=('654de4eba96b8bbf30ec7bd213b67921')
build() {
- cd $srcdir/kitchen-1.1.1
- python2 setup.py build
+ cd $srcdir/kitchen-$pkgver
+ python setup.py build
}
package() {
- cd $srcdir/kitchen-1.1.1
- python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd $srcdir/kitchen-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}