summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44350c7dd705
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Stefan Tatschner <stefan@rumpelsepp.org>
+
+pkgname=python-kitty
+# _module='kitty'
+pkgver=0.7.4
+pkgrel=1
+pkgdesc="Fuzzing framework written in python"
+url="https://github.com/"
+depends=('python')
+makedepends=('python-setuptools')
+license=('GPL')
+arch=('any')
+source=("$pkgname::git+https://github.com/cisco-sas/kitty#tag=v${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}