summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c6ca924e19da..b137ca06d3d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
pkgname=python-kornia
_name=kornia
-pkgver=0.3.1
-pkgrel=2
+pkgver=0.4.0
+pkgrel=1
arch=(any)
url='https://github.com/kornia/kornia'
pkgdesc='Open Source Differentiable Computer Vision Library for PyTorch'
license=(Apache)
makedepends=('python-setuptools')
-depends=('python-pytorch' 'python-numpy')
-checkdepends=('python-pytest' 'python-pytest-runner')
+depends=('python-pytorch' 'python-numpy' 'python-torchvision' 'opencv' 'ipython' 'jupyter' 'python-matplotlib')
+checkdepends=('python-pytest')
options=(!emptydirs)
source=(${_name}-${pkgver}.tar.gz::"${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('b9d45114e14f23cbe24d965f3095e0159b06d5672787959b81d6f9b4242e6c5d')
+sha256sums=('266e3fd4941897d4b35d91861110ae0412c8dc10efafdc73d7b673a0d1974f40')
check() {
cd "${srcdir}/${_name}-${pkgver}"