summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f67df806f89e..e2b8828e17a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,23 @@
pkgname=python-kornia
_name=kornia
-pkgver=0.2.0
+pkgver=0.2.1
pkgrel=1
arch=(any)
url='https://github.com/kornia/kornia'
pkgdesc='Open Source Differentiable Computer Vision Library for PyTorch'
license=(Apache)
makedepends=('python-setuptools')
-depends=('python-pytorch' 'python-pillow' 'python-torchvision' 'opencv' 'python-matplotlib' 'ipython' 'jupyter')
+depends=('python-pytorch' 'python-torchvision' 'opencv' 'python-matplotlib' 'ipython' 'jupyter')
+checkdepends=('python-pytest')
options=(!emptydirs)
source=(${_name}-${pkgver}.tar.gz::"${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('d1f4c34ff89b88549f7f0c3f88ea34565c3cf033fd02920f9288b28461ad331c')
+sha256sums=('95eb4c5f84325e4fff887ef1a8a9f8aeb634bd014031e0c3c08bcd18a5d3cd24')
+check() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ pytest
+}
package() {
cd "${srcdir}/${_name}-${pkgver}"