summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 99a344757919..308c98c4b3ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,15 @@
pkgname=python-kornia-git
_name=kornia
-pkgver=v0.2.0.r8.ge110f3b
+pkgver=0.2.1.r1.g9797eca
pkgrel=1
arch=(any)
url='https://github.com/kornia/kornia'
pkgdesc='Open Source Differentiable Computer Vision Library for PyTorch'
license=(Apache)
-makedepends=(
- 'git'
- 'python-setuptools'
-)
-depends=('python-pytorch' 'python-pillow' 'python-torchvision' 'opencv' 'python-matplotlib' 'ipython' 'jupyter')
+makedepends=('git' 'python-setuptools')
+depends=('python-pytorch' 'python-torchvision' 'opencv' 'python-matplotlib' 'ipython' 'jupyter')
+checkdepends=('python-pytest')
provides=('python-kornia')
conflicts=('python-kornia')
options=(!emptydirs)
@@ -21,7 +19,12 @@ sha256sums=('SKIP')
pkgver() {
cd "${_name}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+check() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ pytest
}
package() {