summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 1 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f7baec0860cf..99547d100f07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,14 +27,9 @@ prepare() {
cp "../build.conf" "$srcdir/kwant/build.conf"
}
-build() {
- cd "$srcdir/kwant"
- python setup.py build
-}
-
package() {
cd "$srcdir/kwant"
- python setup.py install --skip-build --root="$pkgdir"
+ python setup.py install --root="$pkgdir/" --optimize=1
# Install license
install -D -m644 "${srcdir}/kwant/LICENSE.rst" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.rst" || return 1