summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 42a27233d8cf..02520f264d1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
pkgname=python-largestinteriorrectangle
_name=${pkgname#python-}
+_shortname=lir
pkgver=0.2.0
-pkgrel=4
+pkgrel=5
pkgdesc="Largest Interior/Inscribed Rectangle implementation in Python"
arch=('any')
url="https://github.com/OpenStitching/lir"
@@ -14,11 +15,11 @@ source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('ffac62a19b9fdb581c74ae4b8e96834d0baef847cce75443c78feeff1d1045ce')
build() {
- cd "$_name-$pkgver"
+ cd "$_shortname-$pkgver"
python -m build --wheel --no-isolation
}
package() {
- cd "$_name-$pkgver"
+ cd "$_shortname-$pkgver"
python -m installer --destdir="$pkgdir" dist/*.whl
}