summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a3c48fe959b..083b22f2317d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Butui Hu <hot123tea123@gmail.com>
-_pkgname=lazy_loader
+_pkgname=lazy-loader
pkgname=python-lazy-loader
-pkgver=0.3
-pkgrel=1
+pkgver=0.4
+pkgrel=3
pkgdesc='Populate library namespace without incurring immediate import costs'
arch=('any')
url='https://github.com/scientific-python/lazy_loader'
-license=('BSD')
+license=('BSD-3-Clause')
depends=(
python
)
@@ -16,12 +16,13 @@ makedepends=(
python-build
python-wheel
python-installer
+ python-setuptools
)
checkdepends=(
python-pytest
)
source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/scientific-python/lazy_loader/archive/refs/tags/v${pkgver}.tar.gz")
-sha512sums=('559fc96a032ba3882e0e7fe5c85dadf1694b42858cb08ac1d51c7bf972d40ff98aa5c4b07fc855b79369c6e046f717ff141a4bd0554aec8318185f8f20be2a70')
+sha512sums=('3512488bbb3f1699adcbcc7461715d208191b02f8b43b77cc73e703600b13aa7bed62575ffc98ab210ccdb05e8004d5f8f22eaca33fc780afbc1474c15ace8c2')
build() {
cd "${_pkgname}-${pkgver}"
@@ -39,6 +40,6 @@ package() {
install -Dm644 LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
- rm -rfv ${pkgdir}${site_packages}/${_pkgname}/tests
+ rm -rfv ${pkgdir}${site_packages}/lazy_loader/tests
}
# vim:set ts=2 sw=2 et: