summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9b2e7b564722..6a0e819db952 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
-# Maintainer wicastC <wicastchen at hotmail dot com>
+# Maintainer: pumpkincheshire <sollyonzou@gmail.com>
+# Contributor wicastC <wicastchen at hotmail dot com>
pkgname=python-lda
_name=lda
-pkgver=1.0.3
-pkgrel=2
-pkgdesc="Topic modeling with latent Dirichlet allocation"
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Topic modeling with latent Dirichlet allocation using Gibbs sampling"
arch=("i686" "x86_64")
-url="https://github.com/ariddell/lda/"
-license=(MPLv2)
+url="https://github.com/lda-project/lda"
+license=('custom:MPLv2')
depends=("python" "python-numpy" "python-pbr")
makedepends=("python-setuptools")
-source=("http://pypi.python.org/packages/source/l/${_name}/${_name}-${pkgver}.tar.gz")
-md5sums=("17efa4f18d1aa5b08997db709d7ab068")
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('d8d7c0bc42208902a9e34261b76793a84f59e6c69cfd7ca12ce982cdaf7c3020')
build() {
- cd "${srcdir}/${_name}-${pkgver}"
+ cd "$_name-$pkgver"
python setup.py build
}
package() {
- msg "Install..."
- cd "${srcdir}/${_name}-${pkgver}"
- python setup.py install --root="${pkgdir}" || return 1
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ # install -Dm644 $scrdir/README* "${pkgdir}/usr/share/doc/${pkgname}/README"
}