summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a7ed5b0aa545..3061fbfd2a3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@
_base=lesscpy
pkgname=python-${_base}
pkgver=0.15.1
-pkgrel=1
+pkgrel=2
pkgdesc="Python LESS compiler"
url="https://github.com/${_base}/${_base}"
-depends=(python-ply)
-makedepends=(python-setuptools)
+depends=(python-ply python-six)
+makedepends=(python-build python-installer python-setuptools python-wheel)
license=(MIT)
arch=(any)
source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
@@ -16,11 +16,11 @@ sha512sums=('3a88c14d1e47a28d5e427e9cd0e1c2553dd3fc937085c54975c3e2612d623673e0a
build() {
cd ${_base}-${pkgver}
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
cd ${_base}-${pkgver}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}