summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 26 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cf0073dbf691..3a154dc9e31c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,23 @@
-# Maintainer: PumpkinCheshire <sollyonzou@gmail.com>
+#!/bin/bash
+
+# Maintainer: PumpkinCheshire <me at pumpkincheshire dot com>
_name=libpysal
pkgname=python-libpysal
-pkgver=4.4.0
+pkgver=4.6.2
pkgrel=1
pkgdesc="Core components of Python Spatial Analysis Library."
arch=('any')
url="https://pysal.org/libpysal/"
license=('BSD')
-depends=('python-beautifulsoup4' 'python-jinja' 'python-numpy' 'python-pandas' 'python-requests' 'python-scipy')
+depends=(
+ 'python-beautifulsoup4'
+ 'python-jinja'
+ 'python-numpy'
+ 'python-pandas'
+ 'python-requests'
+ 'python-scipy'
+)
optdepends=(
'python-pypandoc: documents'
'python-nbsphinx: documents'
@@ -39,17 +48,24 @@ optdepends=(
'python-black: dev tool'
'python-pre-commit: dev tool'
)
-makedepends=('python-setuptools')
+makedepends=(
+ 'python-wheel'
+ 'python-build'
+ 'python-installer'
+ 'python-pytest-runner'
+)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('216eb73a276d9975e604217bd931dc3b7770a6efa95999952d027827fad51e0c')
+b2sums=('92eac6b46acb8adef6c8d64e63fb85a902d8835888a5fb7bfa31a923d0090186ad00eec00afa7c511ec0db54162f2be734e1329612ec70fa5b30487ad839f435')
build() {
- cd "$_name-$pkgver"
- python setup.py build
+ cd "$srcdir/$_name-$pkgver" || exit
+
+ python -m build --wheel --no-isolation
}
package() {
- cd "$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$srcdir/$_name-$pkgver" || exit
+ python -m installer --destdir="$pkgdir" dist/*.whl
+
+ # install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/python-$_name/LICENSE"
}