summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 16 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6941e2a09b36..e51f5d6ad60c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
-#Contributor: Scott Lawrence <bytbox@gmail.com>
-pkgname=python-libsass
-pkgver=0.7.0
+# Maintainer: Christopher Loen <christopherloen at gmail dot com>
+# Contributor: Scott Lawrence <bytbox@gmail.com>
+pkgname='python-libsass'
+pkgver='0.11.1'
pkgrel=1
pkgdesc="Python binding for libsass CSS compiler"
-arch=(any)
-url="http://dahlia.kr/libsass-python/"
-depends=(python)
-makedepends=(libsass)
-source=(https://pypi.python.org/packages/source/l/libsass/libsass-${pkgver}.tar.gz)
-license=('LGPL')
-
-build() {
- cd $srcdir/libsass-$pkgver
- python setup.py build
-}
+arch=('any')
+url='http://dahlia.kr/libsass-python/'
+depends=('python')
+makedepends=('libsass' 'python2-pip' 'python-pip')
+source=('https://github.com/dahlia/libsass-python/releases/download/0.11.1/libsass-0.11.1.tar.gz')
+license=('MIT')
+sha256sums=('f060d7dab825942ca7f86d0c4adadf7d731a2e30f9bce6e4f010ad7d32adbf06')
package() {
- cd $srcdir/libsass-$pkgver
- python setup.py install --root=$pkgdir
+ echo Installation may be a bit slow, please wait
+ cd ${srcdir}/libsass-${pkgver}
+ pip install --isolated --root="${pkgdir}" --no-deps --ignore-installed .
+ pip2 install --isolated --root="${pkgdir}" --no-deps --ignore-installed .
+
}
-md5sums=('809e4f66bd54eeb46342d7462ce961e6')