summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 47f92f4085c9..85f463d83f41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,28 @@
-_pkgname=libsass
+_name=libsass
pkgname=python-libsass
-pkgver=0.19.4
-pkgrel=2
+pkgver=0.20.1
+pkgrel=1
pkgdesc="Sass for Python: A straightforward binding of libsass for Python."
arch=('x86_64')
url="https://sass.github.io/libsass-python/"
-license=('MIT')
-depends=('python' 'python-six' 'libsass' 'python-setuptools')
-_name=${pkgname#python-}
+license=('MIT License')
+depends=('python-six' 'libsass' 'python-setuptools')
makedepends=('gcc')
provides=('sassc')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_pkgname}-${pkgver}.tar.gz")
-md5sums=('33247c8777f30b03d02163e8fd86b214')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/libsass-0.20.1.tar.gz")
+sha256sums=('e0e60836eccbf2d9e24ec978a805cd6642fa92515fbd95e3493fee276af76f8a')
build() {
- cd "$srcdir/$_pkgname-$pkgver"
- LANG=en_US.UTF-8 python3 setup.py build
+ cd "$srcdir/libsass-0.20.1"
+ python3 setup.py build
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
- LANG=en_US.UTF-8 python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
+ cd "$srcdir/libsass-0.20.1"
+ python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
+
+ # make sure we don't install annoying files
+ local _site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ rm -rf "$pkgdir/$_site_packages/tests/"
}
-# vim:set sw=2 et: