summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f218940fa54a..5584c04b21ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,7 @@
_pkgname=lifelines
pkgname=python-lifelines
-pkgver=0.27.6
-_pkgver=230948c84b3f75c8de3b4b4d935276784256a34b
+pkgver=0.27.7
pkgrel=1
pkgdesc="Survival analysis in Python"
url="https://github.com/CamDavidsonPilon/lifelines"
@@ -12,16 +11,16 @@ license=('MIT')
depends=('ipython' 'python-autograd-gamma' 'python-matplotlib' 'python-pandas' 'python-scikit-learn' 'python-formulaic')
makedepends=('python-setuptools')
options=(!emptydirs)
-source=("${_pkgname}-${pkgver}.tar.gz"::"https://github.com/CamDavidsonPilon/lifelines/archive/230948c84b3f75c8de3b4b4d935276784256a34b.tar.gz")
-sha256sums=('ac0bd52c26b674e2af4c2c609900af1cdee5c891fe39a5a589db95abb2415cad')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/CamDavidsonPilon/lifelines/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('6c445b0782f4ea10bf9afba9109d1bc05d37afff3bd1826ff4604bdc587d45fa')
build() {
- cd "${srcdir}/${_pkgname}-${_pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py build
}
package() {
- cd "${srcdir}/${_pkgname}-${_pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}