summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 444eb80b33be..f218940fa54a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
_pkgname=lifelines
pkgname=python-lifelines
-pkgver=0.27.5
+pkgver=0.27.6
+_pkgver=230948c84b3f75c8de3b4b4d935276784256a34b
pkgrel=1
pkgdesc="Survival analysis in Python"
url="https://github.com/CamDavidsonPilon/lifelines"
@@ -11,16 +12,16 @@ license=('MIT')
depends=('ipython' 'python-autograd-gamma' 'python-matplotlib' 'python-pandas' 'python-scikit-learn' 'python-formulaic')
makedepends=('python-setuptools')
options=(!emptydirs)
-source=("${_pkgname}-${pkgver}.tar.gz"::"https://github.com/CamDavidsonPilon/lifelines/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('31b74719ca1dc3bb378f623ae5ab6539b49ddd2af2fc4af4b56a174d73fc59e0')
+source=("${_pkgname}-${pkgver}.tar.gz"::"https://github.com/CamDavidsonPilon/lifelines/archive/230948c84b3f75c8de3b4b4d935276784256a34b.tar.gz")
+sha256sums=('ac0bd52c26b674e2af4c2c609900af1cdee5c891fe39a5a589db95abb2415cad')
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${_pkgname}-${_pkgver}"
python setup.py build
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${_pkgname}-${_pkgver}"
python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}