summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 259c28e6329f..ac361279dc8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Michael Schubert <mschu.dev at gmail>
pkgname=python-llvmlite
-pkgver=0.28.0
-pkgrel=2
+pkgver=0.38.0
+pkgrel=1
pkgdesc="Lightweight LLVM python binding for writing JIT compilers"
url="https://github.com/numba/llvmlite"
arch=('i686' 'x86_64')
license=('BSD')
-depends=('python' 'llvm7-libs')
-makedepends=('cython' 'llvm7<7.1.0')
-source=("https://github.com/numba/llvmlite/archive/v$pkgver.tar.gz")
-sha256sums=('39868fd2d86cb724ceaac4a34773e47e3b3ba6eeb445b9ac0abaf17a620e74dc')
+depends=('python' 'llvm11-libs>=11.0.0' 'llvm11-libs<12.0.0')
+makedepends=('cython' 'llvm11>=11.0.0' 'llvm11<12.0.0')
+source=(llvmlite-$pkgver.tar.gz::"https://github.com/numba/llvmlite/archive/v$pkgver.tar.gz")
+sha256sums=('90d2d3fa26a410bd976b83f7534dc0dcf484135370ef5bf8d9d7f0103dbc054b')
build() {
cd "$srcdir/llvmlite-$pkgver"