summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4953d4c9b6e7..784009b6b8d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,20 @@
pkgname=python-llvmlite-git
_gitname=llvmlite
-pkgver=0.37.0rc1.r0.g4ba6f53
+pkgver=0.43.0dev0.r0.ga6159f9
pkgrel=1
-pkgdesc="A lightweight LLVM python binding for writing JIT compilers (Git version)"
+pkgdesc="A lightweight LLVM Python binding for writing JIT compilers (Git version)"
url="https://github.com/numba/llvmlite"
arch=('i686' 'x86_64')
license=('BSD')
-depends=('python' 'llvm11-libs')
-makedepends=('git' 'llvm11')
+depends=('python' 'llvm14-libs')
+makedepends=(
+ 'git' 'llvm14' 'python-build' 'python-installer'
+ 'python-setuptools' 'python-wheel'
+)
+optdepends=(
+ 'python-graphviz: visualising control-flow graphs'
+)
provides=("python-llvmlite=$pkgver")
conflicts=('python-llvmlite')
source=(${_gitname}::git+https://github.com/numba/llvmlite.git)
@@ -23,7 +29,7 @@ pkgver() {
build() {
cd "$srcdir/$_gitname"
- python setup.py build
+ LLVM_CONFIG=/usr/bin/llvm-config-14 python -m build --no-isolation --wheel
}
check() {
@@ -32,7 +38,7 @@ check() {
}
package() {
- cd ${srcdir}/${_gitname}
- python setup.py install --skip-build --prefix=/usr --root="$pkgdir" --optimize=1
+ cd "${srcdir}/${_gitname}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}