summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea68a81ec49d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: GI_Jack <GI_Jack@hackermail.com>
+
+pkgname=python-lsassy
+_pypiname=lsassy
+pkgver=2.1.2
+pkgrel=1
+pkgdesc="Python library to remotely extract credentials on a set of hosts"
+url="https://github.com/Hackndo/lsassy"
+arch=('any')
+license=('MIT')
+depends=('python' 'impacket' 'python-netaddr' 'python-pypykatz')
+# Needed pypykatz
+makedepends=('python-setuptools')
+source=(${_pypiname}-${pkgver}.tar.gz::"https://github.com/Hackndo/lsassy/archive/v${pkgver}.tar.gz")
+sha256sums=('7f56af989c944c5e687af1c850cd66949bf79221ae940885e5204da6b8eabcad')
+
+package() {
+ cd ${_pypiname}-${pkgver}
+ python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+}