summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a681662cc2bb..251a689cbbf7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,14 +8,14 @@ pkgdesc='A module to call MATLAB from Python'
arch=(x86_64)
url='https://github.com/mathworks/matlab-engine-for-python'
license=('MIT')
-depends=(matlab python)
-makedepends=(python-build python-installer python-wheel)
+depends=('matlab>=9.14' 'python>=3.8' 'python<3.11')
+makedepends=(python-build python-installer 'python-setuptools>=42' python-wheel)
source=("$url/archive/refs/tags/$pkgver.tar.gz")
b2sums=('491f56fad8007a943b33b9daebcba4a61ca007d93151eaa65394439d4ca9ef1745d4b28e5a41b6dea858da36ecbdaba07b1a6ac0005ebc6373abdc06f3f7fa7e')
build() {
cd $_name-$pkgver
- _malabroot=$(matlab -nodisplay -nojvm -batch "matlabroot" | grep -Eo "/.*[^']")
+ _matlabroot=$(matlab -nodisplay -nojvm -batch "matlabroot" | grep -Eo "/.*[^']")
export LD_LIBRARY_PATH=$_matlabroot/bin/glnxa64
python -m build --wheel --no-isolation
}