summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a764c43b8aa0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Stunts <f.pinamartins@gmail.com>
+
+pkgname=python-matplotlib-venn
+_upstream_pkgname=matplotlib-venn
+pkgver=0.11
+pkgrel=1
+pkgdesc="Functions for plotting area-proportional two- and three-way Venn diagrams in matplotlib"
+arch=('any')
+url="https://pypi.python.org/pypi/matplotlib-venn"
+license=('MIT')
+depends=('python-numpy' 'python-matplotlib' 'python-scipy')
+source=(https://pypi.python.org/packages/source/m/matplotlib-venn/${_upstream_pkgname}-${pkgver}.zip)
+md5sums=('9100680061567a5bb955b5293bcadf9e')
+
+build() {
+ cd "${srcdir}/${_upstream_pkgname}-${pkgver}"
+ yes | python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_upstream_pkgname}-${pkgver}"
+ yes | python setup.py install --root="${pkgdir}"
+}