summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df5e3791dd96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Lorenz Steinert <lsteinert@uraziel.de>
+
+pkgname=python-matrix-synapse-shared-secret-auth-git
+_name=$( expr "${pkgname}" : "python-\(.*\)-git" )
+provides=('python-matrix-synapse-shared-secret-auth')
+conflicts=('python-matrix-synapse-shared-secret-auth')
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="Shared Secret Authenticator password provider module for Matrix Synapse"
+url="https://github.com/devture/matrix-synapse-shared-secret-auth"
+arch=('any')
+license=('AGPL')
+makedepends=('python-setuptools')
+depends=('python')
+source=("git+https://github.com/devture/${_name}.git")
+sha256sums=(SKIP)
+
+build() {
+ cd "${srcdir}/${_name}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}"
+ python setup.py install --root=${pkgdir} --optimize=1 --skip-build
+}