summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b06c772f5ec0..71c7f91c9bc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,23 @@
_pkgbase='mcipc'
pkgname="python-${_pkgbase}"
-pkgver=1.3.0
-pkgrel=1
+pkgver=2.4.2
+pkgrel=2
pkgdesc='Python 3 library and scripts for the RCON and Query protocol'
arch=('any')
url="https://github.com/coNQP/${_pkgbase}"
license=('GPLv3')
-depends=('python')
-makedepends=('git' 'python' 'python-setuptools' 'python-setuptools-git')
+depends=('python' 'python-setuptools' 'python-rcon>=2.3.4')
+makedepends=('git' 'python-build' 'python-installer' 'python-setuptools-scm' 'python-wheel')
source=("${_pkgbase}::git+${url}.git#tag=${pkgver}")
md5sums=('SKIP')
+build() {
+ cd "${srcdir}/${_pkgbase}"
+ python -m build --wheel --no-isolation
+}
package() {
cd "${srcdir}/${_pkgbase}"
- python setup.py install --root "${pkgdir}" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}