summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c26504f83251..645036bc9c34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,25 @@
# Contributor: Zhang Hai <dreaming.in.code.zh@gmail.com>
pkgname=python-mechanicalsoup
-pkgver=1.1.0
+pkgver=1.3.0
pkgrel=1
pkgdesc="A Python library for automating interaction with websites"
arch=('any')
url="https://github.com/hickford/MechanicalSoup"
license=('MIT')
-makedepends=('python-setuptools')
+depends=(python python-beautifulsoup4 python-requests python-six python-lxml)
+makedepends=(python-build python-installer python-wheel)
source=("https://github.com/hickford/MechanicalSoup/archive/v${pkgver}.tar.gz")
check() {
cd $srcdir/MechanicalSoup-$pkgver
- python3 setup.py check
+ python3 -m build --wheel --no-isolation
}
package() {
- depends=('python' 'python-beautifulsoup4' 'python-requests' 'python-six' 'python-lxml')
cd $srcdir/MechanicalSoup-$pkgver
- python setup.py install --root="$pkgdir/" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
-sha512sums=('57f4120f9d6e0e5435d3d20330678fa9dc80215bd8a8009e7873c48b208b28ebe930baacb420f29a7caddd8df7d8e87c6452ba2b26514c6b5d386a1f1df46ae8')
+sha512sums=('68b0ef14e4395b7a97461c5730909e449c1edba9f223efd8066b0e227f28032497eaef84263bd88a82c5b3fa3f1e291eccf483bea7358e4c255f9f6346f5b47a')