summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac1d6bb9c06d..c7ebbc5c99ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,26 +7,20 @@ url='https://github.com/nschloe/meshio'
arch=('x86_64')
license=('MIT')
depends=('python-numpy' 'python-rich')
-makedepends=('python-build' 'python-pip')
+makedepends=('python-build' 'python-installer' 'python-wheel')
optdepends=('python-netcdf4' 'python-h5py')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('710af6e4fa2daed144f7fd58690fa6cbd476956d02b453ecae45787eb0bef3e3')
build() {
cd "meshio-$pkgver"
- python3 -m build .
+ python3 -m build --wheel --no-isolation
}
package() {
- cd "meshio-$pkgver/dist"
- tar zxf "meshio-$pkgver.tar.gz"
-
cd "meshio-$pkgver"
- install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ python -m installer --destdir="$pkgdir" dist/*.whl
- _site=$(/usr/bin/python3 -c 'import sysconfig; print(sysconfig.get_paths()["purelib"])')
- mkdir -p "$pkgdir/$_site/"
- cp -a "src/meshio" "$pkgdir/$_site"
- cp -a "src/meshio.egg-info" "$pkgdir/$_site"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}