summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 32f217eaa300..0805955627da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,11 +11,9 @@ depends=(python-gmsh_interop) # boost
makedepends=(python-setuptools pybind11 git) # ctags
checkdepends=(python-pytest) # python-matplotlib
source=("git+https://github.com/inducer/${_base}.git?signed#tag=v${pkgver}")
-validpgpkeys=("900A958D9A0ACA58B1468F2471AA298BCA171145") # Andreas Kloeckner
+validpgpkeys=('900A958D9A0ACA58B1468F2471AA298BCA171145') # Andreas Kloeckner
sha512sums=('SKIP')
-export PYTHONPYCACHEPREFIX="${BUILDDIR}/${pkgname}/.cache/cpython/"
-
build() {
cd "${_base}"
python3 ./configure.py --python-exe=python3
@@ -31,6 +29,6 @@ check() {
package() {
cd "${_base}"
export PYTHONHASHSEED=0
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}