summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 581d69e32881..59451d428f39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Patrick Lühne <patrick-arch@luehne.de>
pkgname=python-miio
-pkgver=0.5.7
+pkgver=0.5.8
pkgrel=1
pkgdesc="Python library & console tool for controlling Xiaomi smart appliances"
url="https://github.com/rytilahti/python-miio"
@@ -10,22 +10,23 @@ arch=('any')
license=('GPL3')
depends=(
'python>=3.6'
- 'python-appdirs'
+ 'python-appdirs>=1'
'python-attrs'
'python-click>=7'
- 'python-construct'
+ 'python-construct>=2.10.56'
'python-croniter'
- 'python-cryptography'
+ 'python-cryptography>=3'
+ 'python-defusedxml'
'python-netifaces'
'python-pytz'
- 'python-tqdm'
+ 'python-tqdm>=4'
'python-yaml'
'python-zeroconf')
optdepends=('python-android-backup-tools: Android backup extraction support')
makedepends=('python-dephell')
install=miio.install
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha512sums=('d44f48875c72fc85f99859293528c140b9ded80c39c53d4181f499159e75fc95d6625a51d43c1fb1c32f29787346d5e8cc7c12d35103177aaefbcee0aebe5f43')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha512sums=('c2dec86e952e8fd2ea1bbd2db43b2b009e06cc58cfc9611c5655c23105655f12a5e95ae02a018b48531a2d93465bcaf369d48c61e3d8325cfa0982259a2bd79b')
prepare() {
cd "$pkgname-$pkgver"