summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ca7bdde4a8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Butui Hu <hot123tea123@gmail.com>
+
+_pkgname=mmclassification
+pkgname=python-mmclassification-git
+_pkgver=0.1.0
+pkgver=0.1.0.r149.4b46fd6
+pkgrel=1
+pkgdesc='OpenMMLab Image Classification Toolbox and Benchmark'
+arch=('any')
+url='https://github.com/open-mmlab/mmclassification'
+license=('Apache')
+depends=(
+ python-mmcv
+ python-numpy
+ python-pytorch
+)
+makedepends=(
+ git
+ python-setuptools
+)
+provides=(python-mmclassification)
+conflicts=(python-mmclassification)
+source=("${_pkgname}"::git+https://github.com/open-mmlab/mmclassification.git)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "%s.r%s.%s" "${_pkgver}" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+# vim:set ts=2 sw=2 et: