summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0ad71ec296b..5fc1b39049f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,22 @@
-# Maintainer: Phil Schaf <flying-sheep@web.de>
+# Maintainer: Philipp A. <flying-sheep@web.de>
+
_name=modulegraph
pkgname=python-modulegraph
-pkgver=0.12.1
-pkgrel=2
+pkgver=0.17
+pkgrel=1
pkgdesc='determines a dependency graph between Python modules primarily by bytecode analysis for import statements'
arch=('any')
-url="https://bitbucket.org/ronaldoussoren/modulegraph"
-license=('')
+url="https://bitbucket.org/ronaldoussoren/$_name"
+license=('MIT')
depends=('python' 'python-altgraph')
-source=("https://pypi.python.org/packages/source/m/$_name/$_name-$pkgver.tar.gz")
-md5sums=('27abd74de3ec0e22ef129c1faa628bd5')
+_pyarch=py2.py3
+_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
+source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
+sha256sums=('9991538487efaa2d77b78bded12f7ba223f1a143f8ad75ed6484afa70b3d47e1')
+noextract=("$_wheel")
package() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 || return 1
-} \ No newline at end of file
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
+}