summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 10 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0dd5e3a90ef2..be3557af4b64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Maintainer: a821
+# Contributor: Philip Goto <philip.goto@gmail.com>
pkgname=python-msgpack-numpy
-pkgver=0.4.5
+pkgver=0.4.7.1
pkgrel=1
pkgdesc="Serialize numpy arrays using msgpack"
url="https://pypi.org/project/msgpack-numpy/"
@@ -10,24 +11,21 @@ depends=(python-numpy
makedepends=(python-setuptools)
license=(BSD)
arch=(any)
-source=("https://files.pythonhosted.org/packages/06/e5/ab4d8174d1054da471b957c395c7e0b3eadc7aa8073dd9ee3c0e658415f9/msgpack-numpy-0.4.5.tar.gz")
-sha256sums=('af26f6f839b954bf072b3e47f6d954517d6b6d6956d26097331b571545d1747c')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/lebedov/msgpack-numpy/archive/${pkgver}.tar.gz")
+sha256sums=('c1f3fc082efbf733aeb24aa638db622b8f6d6320a82b19116dc97e7afd0ab5cc')
-
-prepare() {
+build() {
cd "msgpack-numpy-${pkgver}"
- chmod 755 msgpack_numpy.egg-info
- chmod 644 $(find . -type f)
- chmod 644 $(find msgpack_numpy.egg-info -type f)
+ python setup.py build
}
-build() {
+check() {
cd "msgpack-numpy-${pkgver}"
- python setup.py build
+ python setup.py test
}
package() {
cd "msgpack-numpy-${pkgver}"
python setup.py install --skip-build --root="$pkgdir" --optimize=1
- install -Dm644 LICENSE.rst "$pkgdir/usr/share/licenses/$pkgname/LICENSE.rst"
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
}