summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 20 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ae12785e2158..1479cb5cdbd9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,28 +5,32 @@
pkgname=python-mutatormath
_pkgname=MutatorMath
pkgver=3.0.1
-pkgrel=1
-pkgdesc='Piecewise linear interpolation in multiple dimensions with multiple, arbitrarily placed, masters'
-arch=('any')
+pkgrel=2
+pkgdesc='Piecewise linear interpolation of multiple, arbitrarily placed, masters'
+arch=(any)
url='https://github.com/LettError/MutatorMath'
-license=('BSD')
-depends=('python' 'python-fonttools' 'python-defcon' 'python-fontmath')
-makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.zip")
+license=(BSD)
+depends=(python
+ python-defcon
+ python-fontmath
+ python-fonttools)
+makedepends=(python-setuptools)
+_archive="$_pkgname-$pkgver"
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_archive.zip")
sha256sums=('8127c1ffad1646f11a953752296c43f5d88cbd5293fff03f093d916b0bc13864')
-check() {
- cd "$_pkgname-$pkgver"
- python setup.py test
+build() {
+ cd "$_archive"
+ python setup.py build
}
-build() {
- cd "$_pkgname-$pkgver"
- python setup.py build
+check() {
+ cd "$_archive"
+ python setup.py test
}
package() {
- cd "$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$_archive"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
}