summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2989d67fb067..9a1afc86104a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Simon Tas <simon.tas.st@gmail.com>
pkgname="python-myougiden-git"
_pkgname="myougiden"
-pkgver=0.8.8
+pkgver=0.8.5.r26.gddb3987
pkgrel=1
pkgdesc="A command-line, Japanese/English English/Japanese dictionary"
arch=('any')
@@ -16,6 +16,11 @@ backup=('etc/myougiden/config.ini')
source=("git+https://github.com/leoboiko/${_pkgname}")
md5sums=('SKIP')
+pkgver() {
+ cd ${srcdir}/${_pkgname}
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
cd ${srcdir}/${_pkgname}
python setup.py build