summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6fb67800f00..164eb0a3b249 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Don't bump to 2.X until we have Anki >= 2.1.41
pkgname=python-mypy-protobuf
-pkgver=2.9
+pkgver=3.5.0
pkgrel=1
pkgdesc='Generate mypy stub files from protobuf specs'
@@ -9,18 +9,18 @@ arch=('any')
license=('Apache')
depends=('mypy' 'protobuf' 'python' 'python-protobuf')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel')
source=("https://files.pythonhosted.org/packages/source/m/mypy-protobuf/mypy-protobuf-$pkgver.tar.gz")
-sha256sums=('278172935d7121c2f8c7c0a05518dd565a2b76d9e9c4a0a3fcd08a21fa685d43')
+sha256sums=('21f270da0a9792a9dac76b0df463c027e561664ab6973c59be4e4d064dfe67dc')
build() {
cd mypy-protobuf-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd mypy-protobuf-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}