summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e820270890b0..8365acc10eec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgbase=python-myst-nb
-#_pyname=${pkgbase#python-}
_pname=${pkgbase#python-}
_pyname=MyST-NB
+#_pyname=${_pname//-/_}
pkgname=("python-${_pname}")
-pkgver=0.17.2
+pkgver=1.0.0
pkgrel=1
pkgdesc="Parse and execute ipynb files in Sphinx"
arch=('any')
@@ -23,11 +23,11 @@ makedepends=('python-flit-core'
checkdepends=('python-pytest-param-files'
'python-pytest-regressions'
'python-beautifulsoup4'
- 'python-importlib-metadata'
+# 'python-importlib-metadata'
'python-ipywidgets'
'python-jupyter-cache'
'python-matplotlib'
- 'python-myst-parser<0.19'
+ 'python-myst-parser'
'python-nbdime'
'python-pandas'
'python-sphinx'
@@ -40,7 +40,7 @@ checkdepends=('python-pytest-param-files'
#source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
source=("https://github.com/executablebooks/MyST-NB/archive/refs/tags/v${pkgver}.tar.gz")
# 'Makefile')
-md5sums=('eabb0ca11ec2a7e161ebb001ec88439f')
+md5sums=('9be8bfdf91399fe6e155f25c3a5694ed')
#prepare() {
# cd ${srcdir}/${_pyname}-${pkgver}
@@ -63,7 +63,7 @@ check() {
mkdir -p dist/lib
bsdtar -xpf dist/${_pname/-/_}-${pkgver}-py3-none-any.whl -C dist/lib
- PYTHONPATH="dist/lib:${PYTHONPATH}" pytest || warning "Tests failed" # -vv --color=yes
+ PYTHONPATH="dist/lib:${PYTHONPATH}" pytest || warning "Tests failed" # -vv -l -ra --color=yes -o console_output_style=count
# --deselect=tests/test_execute.py::test_custom_convert_auto \
# --deselect=tests/test_execute.py::test_custom_convert_cache
}
@@ -73,9 +73,9 @@ package_python-myst-nb() {
'ipython'
'python-jupyter-cache>=0.5'
# 'python-jupyter-sphinx'
- 'python-myst-parser<0.19'
+ 'python-myst-parser>=1.0.0'
'jupyter-nbclient' # depends on nbformat
- 'python-sphinx'
+ 'python-sphinx>=5'
'python-yaml'
'python-typing_extensions'
'python-ipykernel')