summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af5089acd7cb..8dca5c58604d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=('python-nexpy' 'python2-nexpy')
_pkgname=nexpy
pkgver=0.10.10
-pkgrel=1
+pkgrel=2
pkgdesc="NeXpy: A Python GUI to analyze NeXus data"
url="http://nexpy.github.io/nexpy"
arch=("any")
@@ -26,6 +26,7 @@ package_python2-nexpy() {
depends=('python2-numpy' 'python2-h5py' 'python2-scipy' 'python2-nexusformat' 'ipython2-notebook' 'python2-matplotlib' 'python2-subprocess32')
cd "$srcdir/$_pkgname-$pkgver-py2"
sed -i 's/jupyter/jupyter_core/' src/nexpy/requires.py # Can't find jupyter at run time
+ sed -i '/ansi2html/d' src/nexpy/requires.py # remove ansi2html from requires
python2 setup.py install --root="$pkgdir/" --optimize=1
# Conflict with python3 version
mv $pkgdir/usr/bin/nexpy{,2}