summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ca471dab1821..bb87d5d2e9c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=python-norbert
pkgver=0.2.1
-pkgrel=1
+pkgrel=2
pkgdesc='Painless Wiener filters for audio separation'
arch=('any')
url='https://github.com/sigsep/norbert'
license=('MIT')
-depends=('python-scipy')
+depends=('python' 'python-numpy' 'python-scipy')
checkdepends=('python-pytest')
makedepends=(
'python-build'
@@ -24,6 +24,13 @@ sha512sums=(
'd10abce6d06377def4b4fcec22ffe1a0bde74600b6d90f6a87d9f726284ba895c26af088ba78b537b82bc4797af5d5d924e8deeea3f88e3af119c1f9396058ea'
)
+prepare() {
+ cd "${srcdir}/${pkgname#python-}-${pkgver}"
+
+ # Compatibility fix for setuptools
+ sed -i -e 's/description-file/description_file/' setup.cfg
+}
+
build() {
cd "${srcdir}/${pkgname#python-}-${pkgver}"
python -m build --wheel --no-isolation