summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index deafc2a71e5a..c9b36eb87c08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=python-oath
pkgname=('python-oath' 'python2-oath')
pkgver=1.4.0
-pkgrel=6
+pkgrel=7
pkgdesc="Python implementation of HOTP, TOTP and OCRA algorithms from OATH."
arch=('any')
url="https://github.com/bdauvergne/python-oath"
@@ -21,7 +21,13 @@ build() {
cd "../python-oath-$pkgver-py2" && python2 setup.py build
}
+check() {
+ cd "python-oath-$pkgver" && python setup.py test
+ cd "../python-oath-$pkgver-py2" && python2 setup.py test
+}
+
package_python-oath() {
+ depends=('python')
cd "python-oath-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$pkgname/"
@@ -29,6 +35,7 @@ package_python-oath() {
}
package_python2-oath() {
+ depends=('python2')
cd "python-oath-$pkgver-py2"
python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$pkgname/"