summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 18 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1e9170f9ce1d..f7c1ea10e207 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,33 @@
-# Maintainer: Christian Rebischke <chris.rebischke[at]archlinux[dot]org>
+# Maintainer: Brad Ackerman <brad[at]facefault.org>
+# Contributor: Christian Rebischke <chris.rebischke[at]archlinux[dot]org>
_pyname=oletools
-pkgname=python2-oletools
-pkgver=0.51
+pkgname=python-oletools
+pkgver=0.54.2
pkgrel=1
pkgdesc="Python tools to analyze security characteristics of MS Office and OLE files"
-depends=('python2')
+depends=('python'
+ 'python-colorclass'
+ 'python-easygui'
+ 'python-pyparsing'
+ 'python-msoffcrypto-tool')
arch=('any')
url="https://github.com/decalage2/oletools"
license=('BSD')
-source=("${_pyname}-${pkgver}.tar.gz::https://github.com/decalage2/oletools/archive/v${pkgver}.tar.gz")
-sha512sums=('030da6195af1554ca8725eb41f7c0974aa26028340d296d165f7797179bc6b076e31a5cc061addc6b357115ed62976bcf7fe9369c67d7b6629baa17ff12f535d')
+source=("https://github.com/decalage2/oletools/releases/download/v${pkgver}b/${_pyname}-${pkgver}.tar.gz")
+sha512sums=('8399ff65379f63d647e0a58660a77eee22436df9c6cc4baca413ed762750f9d89c8c7d326a94a42a69c357d1abd33b2ddf9cb5b0595a6df9c5606ed461215b06')
+
+# Some checks failing; will investigate. -BA 20190616
+# check() {
+# cd "${srcdir}/${_pyname}-${pkgver}"
+# python3 setup.py test
+# }
package() {
cd "${srcdir}/${_pyname}-${pkgver}"
- python2 setup.py install -O1 --root="${pkgdir}"
+ python3 setup.py install -O1 --root="${pkgdir}"
install -Dm 644 ${_pyname}/LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README"
cp ${_pyname}/doc/* "${pkgdir}/usr/share/doc/${pkgname}"
-
- # fixing shebang line
- cd "${pkgdir}/usr/lib/python2.7/site-packages/oletools/"
- for file in *.py; do
- if [ "${file}" != "__init__.py" ]; then
- sed -i '1s/python/python2/' "${file}"
- fi
- done
}
# vim:set et sw=2 ts=2 tw=79: