summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e1a621f7aba0..f6ce1c58466b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-onnx
pkgver=1.6.0
-pkgrel=4
+pkgrel=6
pkgdesc='Open Neural Network Exchange'
arch=('x86_64')
url='https://onnx.ai'
@@ -34,6 +34,10 @@ optdepends=(
source=("${pkgname}::git+https://github.com/onnx/onnx.git#tag=v${pkgver}")
sha512sums=('SKIP')
+get_pyver () {
+ python -c 'import sys; print(str(sys.version_info[0]) + "." + str(sys.version_info[1]))'
+}
+
prepare() {
cd "${srcdir}/${pkgname}"
git submodule update --init --recursive
@@ -46,7 +50,7 @@ build() {
check() {
cd "${srcdir}/${pkgname}"
- PYTHONPATH=$(pwd)/build/lib.linux-$CARCH-3.7 pytest -v
+ PYTHONPATH="$(pwd)/build/lib.linux-${CARCH}-$(get_pyver)" pytest -v
}
package() {