summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 33a2035fde49..181ac81b0bc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgbase=python-onnxruntime
pkgname=(python-onnxruntime python-onnxruntime-cuda)
-pkgver=0.5.1
+pkgver=1.0.0
pkgdesc='Cross-platform, high performance scoring engine for ML models'
pkgrel=2
arch=(x86_64)
url='https://github.com/microsoft/onnxruntime'
license=(MIT)
depends=(protobuf re2 python-numpy)
-makedepends=(git cmake cuda cudnn gtest gmock pybind11 python-setuptools)
+makedepends=(git cmake cuda cudnn gtest gmock pybind11 python-setuptools cub)
# not de-vendored libraries
# eigen: API changes a lot since extra/eigen 3.3.7 to the commit onnxruntime uses
# onnx: onnxruntime requires headers, which are not installed in python-onnx
@@ -17,7 +17,6 @@ source=("git+https://github.com/microsoft/onnxruntime#tag=v$pkgver"
"git+https://github.com/HowardHinnant/date.git"
"eigen::git+https://github.com/eigenteam/eigen-git-mirror.git"
"git+https://github.com/google/gemmlowp.git"
- "gsl::git+https://github.com/Microsoft/GSL.git"
"git+https://github.com/google/nsync.git"
"git+https://github.com/onnx/onnx.git"
build-fixes.patch)
@@ -27,8 +26,7 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- '14371770514544fbb25016fb6b986501911ca5683584c45855325fa7447dbf8f10735c8d57239996c5ee3dc7cce2a3238150c04564529769c9dcb7edb47e799e')
+ 'da8e27ff0011fb207ee8a6f8675160eb85cb8711f01050fa7454234242af141951cb5bba52fa50b98cf8567b8faa973565dfef37f4daa2219a42cf26e03c86b5')
prepare() {
cd onnxruntime
@@ -39,7 +37,7 @@ prepare() {
patch -Np1 -i ../build-fixes.patch
git submodule init
- for mod in date eigen gemmlowp gsl nsync onnx ; do
+ for mod in date eigen gemmlowp nsync onnx ; do
git config submodule.cmake/external/$mod.url "$srcdir"/$mod
git submodule update cmake/external/$mod
done