summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 13 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3cda6787d0ba..8f6cf9d2bb7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Chih-Hsuan Yen <yan12125@gmail.com>
pkgname=python-onnxruntime
-pkgver=1.3.1
+pkgver=1.4.0
pkgdesc='Cross-platform, high performance scoring engine for ML models'
-pkgrel=1
+pkgrel=2
arch=(x86_64)
url='https://github.com/microsoft/onnxruntime'
license=(MIT)
-depends=(protobuf re2 python-numpy)
-makedepends=(git cmake pybind11 python-setuptools nlohmann-json chrono-date)
+depends=(nsync re2 python-numpy python-onnx python-protobuf)
+makedepends=(git cmake gtest gmock pybind11 python-setuptools nlohmann-json chrono-date)
# not de-vendored libraries
# eigen: API changes a lot since extra/eigen 3.3.7 to the commit onnxruntime uses
# onnx: onnxruntime uses different protobuf files than upstream onnx
@@ -16,34 +16,23 @@ makedepends=(git cmake pybind11 python-setuptools nlohmann-json chrono-date)
source=("git+https://github.com/microsoft/onnxruntime#tag=v$pkgver"
"git+https://gitlab.com/libeigen/eigen.git"
"git+https://github.com/google/gemmlowp.git"
- "git+https://github.com/google/nsync.git"
"git+https://github.com/onnx/onnx.git"
"git+https://github.com/dcleblanc/SafeInt.git"
- "git+https://github.com/microsoft/wil.git"
- build-fixes.patch
- gcc10.diff
- protobuf-debundle.patch)
+ build-fixes.patch)
sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- 'SKIP'
- '8ece04a7f2ffc89aa9da0a34db1febf31a0516dc2271f2fa711e8160577b2195ba746c150ed76506ce378e913be2888947e21d5745e52fe6d248b1d5aa7f2a83'
- 'cc4fe39dba1d1565ebea51c90fa81ea18975d12db60468d6508b386d1423e5500b3579bce7c5d633a5504163248f5278aaaca6374b90c282344575b911dd852a'
- 'a147afdd18d68f7aa5ba06f69993d06876e9c80bfe42dedf7e279576a2fc19a177f6441122cde905771b57fc747a561d215df8729cd0ca6289cf1fbc398efd30')
+ '6e696c527fb616145910689d5b7ac2090365cedd5e4d9c76baaacbe55ac9bc8d6acc8759874e1eb0f817e0ecaa29e6b66ad2e967785fa00b2d5da50b8c1ffb15')
prepare() {
cd onnxruntime
patch -Np1 -i ../build-fixes.patch
- # part of https://github.com/microsoft/onnxruntime/commit/e86214e5c00ffbb95b85478c111c8eb21de94fe9
- patch -Np1 -i ../gcc10.diff
- patch -Np1 -i ../protobuf-debundle.patch
git submodule init
- for mod in eigen gemmlowp nsync onnx SafeInt wil; do
+ for mod in eigen gemmlowp onnx SafeInt; do
git config submodule.cmake/external/$mod.url "$srcdir"/$mod
git submodule update cmake/external/$mod
done
@@ -57,14 +46,18 @@ build() {
-Donnxruntime_ENABLE_PYTHON=ON \
-DONNX_CUSTOM_PROTOC_EXECUTABLE=/usr/bin/protoc \
-Donnxruntime_PREFER_SYSTEM_LIB=ON \
- -Donnxruntime_USE_FULL_PROTOBUF=OFF \
- -Donnxruntime_BUILD_UNIT_TESTS=OFF
+ -Donnxruntime_USE_FULL_PROTOBUF=OFF
cd build
make
python ../setup.py build
}
+check() {
+ cd onnxruntime/build
+ make test
+}
+
package() {
cd onnxruntime/build
python ../setup.py install --root="$pkgdir" --skip-build --optimize=1