summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 18720f153526..eb543674455e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Jeff Henson <jeff@henson.io>
# Old Maintainer: Giacomo Longo <gabibbo97@gmail.com>
+
pkgname=python-openshift
-pkgver=0.10.2
+pkgver=0.10.3
pkgrel=1
pkgdesc="Python client for the OpenShift API"
url="https://github.com/openshift/openshift-restclient-python"
license=('APACHE')
-_name=${pkgname#python-}
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('10868c5697c7610e1d18d62118f1bf2096d35789fa9790c89285947a93545a8a')
+source=("https://github.com/openshift/openshift-restclient-python/archive/v${pkgver}.tar.gz")
+sha256sums=('05da5b323e1be23d6cf6f1e4eadd984021e023d5330262f79e963b500b407112')
arch=('any')
makedepends=('python-setuptools')
depends=(
@@ -22,11 +22,11 @@ depends=(
)
build() {
- cd "$srcdir/$_name-$pkgver"
+ cd openshift-restclient-python-${pkgver}
python setup.py build
}
package() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ cd openshift-restclient-python-${pkgver}
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
}