summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 2 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 961407b5698c..8da7ab658b27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
# Contributor: Alexandr Parkhomenko <it@52tour.ru>
pkgname=python-opentsne-git
-pkgver=1.0.0.r12.g2f7eb25
+pkgver=1.0.2.r0.g9715ac8
pkgrel=1
pkgdesc="Extensible, parallel implementations of t-SNE"
url="https://opentsne.readthedocs.io/en/latest/"
arch=('x86_64')
-license=('BSD')
+license=('BSD-3-Clause')
depends=('fftw' 'python-scikit-learn')
makedepends=('cython' 'git' 'python-setuptools' 'python-build' 'python-installer' 'python-wheel')
optdepends=(
@@ -24,11 +24,6 @@ pkgver () {
git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./g'
}
-prepare() {
- cd "openTSNE"
- sed -i 's/oldest-supported-//' pyproject.toml
-}
-
build() {
cd "openTSNE"
python -m build --wheel --no-isolation