summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d8216c99a3d2..49d3040725c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Alexandr Parkhomenko <it@52tour.ru>
pkgname=python-opentsne-git
-pkgver=1.0.0.r1.gb9662b5
+pkgver=1.0.0.r3.g994cf0b
pkgrel=1
pkgdesc="Extensible, parallel implementations of t-SNE"
url="https://opentsne.readthedocs.io/en/latest/"
@@ -16,8 +16,10 @@ optdepends=(
)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("git+https://github.com/pavlin-policar/openTSNE.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/pavlin-policar/openTSNE.git"
+ "fix_get_numpy_include.patch")
+sha256sums=('SKIP'
+ 'b7e2ef8a66e665851333a93a44dd0d6d657d6d77988dc159a14b14abeead20a1')
pkgver () {
cd "openTSNE"
@@ -27,6 +29,7 @@ pkgver () {
prepare() {
cd "openTSNE"
sed -i 's/oldest-supported-//' pyproject.toml
+ patch -p1 < ../fix_get_numpy_include.patch
}
build() {