summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0e1bf470730..919121cb89c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,22 @@ _project=otf-python
_pyname=opentype-sanitizer
pkgname=python-$_pyname
pkgver=8.0.0.post2
-pkgrel=2
+pkgrel=3
pkgdesc='Python wheels for the OpenType Sanitizer'
arch=('any')
url="https://github.com/googlefonts/$_project"
license=('GPL3')
-depends=('freetype2'
- 'python'
- 'zlib')
-makedepends=('meson' 'ninja' 'python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_pyname-$pkgver.tar.gz")
-sha256sums=('95bbd6ce193841654aef95237e95197addbc0495daa9da2947f64f5ccd86ef38')
+depends=('python' 'ots')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_pyname-$pkgver.tar.gz"
+ system-ots-sanitize.patch)
+sha256sums=('95bbd6ce193841654aef95237e95197addbc0495daa9da2947f64f5ccd86ef38'
+ '6388d57e44f3dc7d6ee91422b30ca9eca3e3c590bacaa7bc4664b6183ed4d065')
+
+prepare () {
+ cd "$_pyname-$pkgver"
+ patch -p0 < "$srcdir/system-ots-sanitize.patch"
+}
build() {
cd "$_pyname-$pkgver"