summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 08f3897c0b89..d4f466341c30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Bert Peters <bert@bertptrs.nl>
pkgname=python-opnieuw
-pkgver=1.2.1
+pkgver=2.0.0
pkgrel=1
pkgdesc="A general-purpose retrying library, written in pure Python"
arch=('any')
@@ -8,9 +8,8 @@ url="https://github.com/channable/opnieuw"
license=('BSD')
depends=('python')
makedepends=('python-setuptools')
-checkdepends=('python-pytest')
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('43b220cea505ac3e23eaf5cc8e180c673a85ee7ce9d60b2fd3fcc3a60ec19304')
+sha256sums=('a34484e2f7b136649691eeefc89f46a95783b3ccab0cc33c118713c037374397')
build() {
cd "opnieuw-$pkgver"
@@ -19,7 +18,7 @@ build() {
check() {
cd "opnieuw-$pkgver"
- pytest tests
+ python -m unittest
}
package() {