summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..059dd30b2e3d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Alexandr Parkhomenko <it@52tour.ru>
+
+_author=biolab
+_pkgname=orange-widget-base
+pkgname=python-$_pkgname-git
+pkgver=1
+pkgrel=1
+pkgdesc="Base widget and workflow definitions for Orange."
+arch=('i686' 'x86_64')
+url="http://orange.biolab.si/"
+license=('GPL3')
+makedepends=('python-setuptools')
+depends=('python-chardet' 'python-docutils' 'python-pyqtgraph' 'python-xlrd' 'python-matplotlib' 'python-scikit-learn' 'python-psycopg2' 'python-joblib' 'python-keyrings-alt' 'python-bottleneck' 'python-anyqt' 'qt5-svg' 'python-pip' 'python-serverfiles' 'python-louvain' 'python-xlsxwriter' 'python-opentsne' 'python-networkx' 'python-requests' 'python-pandas')
+provides=('python-orange-widget-base')
+source=("git://github.com/$_author/$_pkgname")
+sha256sums=('SKIP')
+
+pkgver () {
+ cd "$srcdir/$_pkgname"
+ git describe --tags --long | sed -r 's/^v//;s/-RC/RC/;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/orange-widget-base-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/orange-widget-base-$pkgver"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+