summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 20 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e03388a9bf4d..67111a212356 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,38 +5,40 @@
_pkgname='osmnx'
pkgname="python-${_pkgname}"
-pkgver=1.2.2
+pkgver=1.6.0
pkgrel=1
pkgdesc='Retrieve, model, analyze, and visualize OpenStreetMap street networks and other spatial data'
arch=('any')
url='https://github.com/gboeing/osmnx'
_url_pypi='https://pypi.org/project/osmnx'
license=('MIT')
-depends=('python-descartes'
- 'python-folium'
- 'python-geopandas'
- 'python-matplotlib'
- 'python-networkx'
- 'python-numpy'
- 'python-pandas'
- 'python-pyproj'
- 'python-requests'
- 'python-rtree'
- 'python-scikit-learn'
- 'python-scipy'
- 'python-shapely')
-makedepends=('python-setuptools')
+depends=(
+ 'python-geopandas'
+ 'python-networkx'
+ 'python-numpy'
+ 'python-pandas'
+ 'python-requests'
+ 'python-shapely'
+)
+optdepends=(
+ 'python-matplotlib: for visualization'
+ 'python-scipy: for entropy'
+ 'python-scikit-learn: for neighbors'
+ 'python-gdal: for rasterization'
+ 'python-rasterio: for rasterization'
+)
+makedepends=('python-build' 'python-installer' 'python-wheel' 'python-hatchling')
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('30924452ca02758ece3301f9fcfb1b80edf31e2be7abe7fa7e0fefddb5050408')
+sha256sums=('719c4dc00c2b489ea9e71a382b9e032721db462d9955edbbf740cd799d93feb3')
build() {
cd "${_pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
install -Dvm644 'LICENSE.txt' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}